[Chilli] 1.2.9 compilation problem (compiled as part of openwrt)

Adam Hammond adam at freerunr.com
Thu Feb 2 16:45:45 UTC 2012


There seems to be a problem compiling under openwrt if the --proxyvsa option is specified.

Here's some output:

libtool: compile:  mips-openwrt-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I.. -I/home/build/builds/backfire-10.3.1-RC6/staging_dir/target-mips_r2_uClibc- -I/home/build/builds/backfire-10.3.1-RC6/staging_dir/target-mips_r2_uClibc- -I/home/build/builds/backfire-10.3.1-RC6/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc- -I/home/build/builds/backfire-10.3.1-RC6/staging_dir/toolchain-mips_r2_gcc-4.3.3+cs_uClibc- -D_GNU_SOURCE -Wall -Werror -fno-builtin -fno-strict-aliasing -O2 -fomit-frame-pointer -funroll-loops -pipe -I../bstring -DDEFCHILLICONF=\"/etc/chilli.conf\" -DDEFPIDFILE=\"/var/run/chilli.pid\" -DDEFSTATEDIR=\"/var/run\" -DSBINDIR=\"/usr/sbin\" -I../json -Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time -fhonour-copts -msoft-float -MT dhcp.lo -MD -MP -MF .deps/dhcp.Tpo -c dhcp.c  -fPIC -DPIC -o .libs/dhcp.o
cc1: warnings being treated as errors
dhcp.c: In function 'dhcp_handler':
dhcp.c:3007: error: unused variable 'appconn'
make[7]: *** [dhcp.lo] Error 1
make[7]: Leaving directory `/home/build/builds/backfire-10.3.1-RC6/build_dir/target-mips_r2_uClibc-'
make[6]: *** [all-recursive] Error 1

I've tried compiling it under several different versions of openwrt, all with the same error.

I've compiled it manuallyfrom src, and DON'T get any error.

I'm not quite sure how to fix this, but I'll plug away come back on this if I work it out.


More information about the Chilli mailing list