[Chilli] Coova Chilli only working without --fg --debug?

Steffen Dettmer steffen.dettmer at nomadrail.com
Thu Jan 31 10:08:40 UTC 2013


I tried /etc/init.d/chilli start ; /etc/init.d/chilli stop ; chilli --fg --debug
But didn't even made it to receive a redirect on the client. I tried for
hours while trying hints proposed by Google...

Going desperate, I tried /etc/init.d/chilli start and suddenly get redirect
to a working login form and finally ended up at the original page!

Is there an issue with --fg --debug?

[it seems to be reproducible, when stopping and running --fg --debug again,
I don't even get any redirect; /etc/init.d/chilli start and things are fine.]

Syslog is a bit brief in this mode  of operation (fine if it works, but a
bit too brief for troubleshooting), can it be increased by some option?

Any comments appreciated.


I followed [1] using [2], but my setup is a bit more complex and involves
OpenVPN bridging to get the client network to the Coova Chilli box and
is using two Virtual Box appliances.
[1] https://help.ubuntu.com/community/WifiDocs/CoovaChilli
[2] http://coova-chilli.s3.amazonaws.com/coova-chilli_1.3.0_i386.deb

More information about the Chilli mailing list