DNS only works with dnsparanioa

lc chilli at silverserver.at
Mon Apr 14 10:10:19 UTC 2008


great to see so much progress!

just tried SVN 163 and ran into a DNS related issue. I run coova- 
chilli on OpenWRT which acts as DNS server as well. Therefore the  
option dns1 is set to the IP address of the tun0 interface  

This setup was working with SVN 159; with 163 it is not working  
anymore. The client simply does not get any replies to dns requests.

I played a little and found a work-around:
as soon as I start chilli with the dnsparania option everything works  
as it should. Without it it seems chilli gets so paranoid that it  
refuses to handle dns requests at all :)


Am 11.04.2008 um 19:04 schrieb wlan at mac.com:
> http://coova.org/wiki/index.php/CoovaChilli/ChangeLog
> Recent changes include:
> 	• Bug fix in RADIUS timeout, note that option radiustimeout is in  
> seconds!
> 	• Fix for dnsparanoia whereby chilli will reply with a host not  
> found error instead of dropping the packet suggest by nextime
> 	• New option macauthdeny which will result in the black-listing of  
> devices given an Access-Reject during MAC address authentication
> 	• New internal state called splash in which clients are given  
> Internet access, but enforcing the port 80 http redirect
> 	• new option dhcpradius for mapping of some DHCP options into  
> RADIUS attributes and visa versa during MAC authentication
> 	• new options dhcpgateway and dhcpgatewayport to specific a DHCP  
> gateway (relay) host IP Address and port
> 	• New option (in development) routeif to specify which WAN  
> interface to use for the default - this also enables the use of  
> internal routing instead of everything defaulting to the tun/tap

More information about the Chilli mailing list